Following the database maintenance, our metrics have shown a significant improvement, and we are currently monitoring the environment for stability. Users are now able to login and navigate Dash as expected without latency and the impacted Platform/ETL processes are working as expected. We will continue to investigate root cause.
Posted May 30, 2025 - 09:04 PDT
Update
Teams continue to investigate this issue. Later today, we are planning on performing database maintenance which will also include a database restart around 5PM PST. Additionally, yesterday we engaged AWS support to help aid our investigation efforts. We have also identified that the database latency is also impacting some Platform/ETL processes where there is a dependency on the database. To combat this, teams have increased system resources to help combat the database latency. We will continue to provide updates as we make progress towards resolution and appreciate your patience.
Posted May 29, 2025 - 09:36 PDT
Update
The potential resolution solution did not succeed; teams continue to investigate the issue.
Posted May 27, 2025 - 16:20 PDT
Update
Teams continue to investigate this issue; however, we believe we have identified a potential root cause and are exploring remediation options and will be implementing a possible solution in the next few minutes. We will continue to advise you of progress as we continue to work towards resolution of this issue.
Posted May 27, 2025 - 13:32 PDT
Identified
We are currently investigating an issue where some users are experiencing latency while signing into and navigating the Dash analytics webpages.
We have identified that this issue has been ongoing since 5/14 and that it is affecting approximately 1% of the overall users that have more than 10+ clients assigned to their Dash profile. Given the scope of impact, we will be addressing this issue following the holiday weekend and we will provide updates as we make progress remediating this issue.
Posted May 23, 2025 - 16:04 PDT
This incident affected: Dashboard/Site Availability (iSpot Analytics).